New MX500 isn't picked up by Windows 10 Disk Management

SOLVED
Kilobyte Kid

New MX500 isn't picked up by Windows 10 Disk Management

My new MX500 (500Gb SSD) isn't being picked up by Windows 10 Disk Management. It's in the BIOS. It's shown in Device Manager, also. It's also picked up by Crucial Storage Executive, and shown as healthy. But not in Disk Manager, so I can't format it/use it. I've also tried 3rd party tools such as Minitool Partition Wizard...the SSD isn't being shown there either. 

 

I've tried three diferent Windows 10 PCs, of varying ages (2 x desktops via SATA connection & 1 x laptop via USB connector & bridge) - same result with all three.

 

Any ideas? Faulty SSD?

Tags (1)
2 Replies
JEDEC Jedi

Re: New MX500 isn't picked up by Windows 10 Disk Management

If Crucial Storage Executive can see the drive, then perform a Sanitize/Secure Erase or PSID revert on it (the MX500 needs to be connected to an internal controller set for AHCI mode or to eSATA for this to work).  This will erase the SSD.  May need a reboot after. 

 

To confirm this is a Windows issue.  I would download Knoppix and boot it using a USB  drive.   I believe Knoppix has a couple of GUI apps for partitioning & formating drives called Disks and GParted.  If you have a UEFI system with Secure Boot, then Secure Boot will need to be disabled in order to boot Knoppix.  If you are using BitLocker make sure to have your Recovery Key in order to access it after re-enabling Secure Boot.  If your system is UEFI then partition the MX500 as GPT to match otherwise as MBR so Windows may have a better chance of seeing it.

Kilobyte Kid

Re: New MX500 isn't picked up by Windows 10 Disk Management

Sanitizing the SSD using the Crucial Storage Executive, did the job, thanks. It still wasn't that strightforward, as I had the PC/SSD running in IDE mode rather than AHCI....so before sanitize would work, I had to switch to AHCI in the BIOS and update the Windows drivers for same - instruction below!

 

Start REGEDIT and look for this line :
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\StartOverride
Change the 0 DWORD value from 3 to 0.
Reboot, and change your SATA controller to AHCI in BIOS. Now let it boot into safe mode, WIN 10 will install required drivers for AHCI.
Now with a normal boot you will boot into Windows with AHCI drivers. 

 

Once the PC rebooted after that lot, sanitize did it's job and hey presto, the drive became visible in Disk Manager. Job done.

Tags (2)