OSStatus 28 Error on Restore Mac Mojave APFS

Bit Baby

OSStatus 28 Error on Restore Mac Mojave APFS


I’m having problems performing a restore operation using Mac Disk utility.

I initialised the drive ok as name ‘SDD’ (typo) and on restore when ‘Validating sizes...’ get error “Not enough space on /volume/SDD/ContainerToInvert to restore. The operation could not be completed. (OSStatus error 28.)”

The existing hard drive is 500gb SATA, formatted as AFPS. New SSD is 500gb.

I can’t see why system thinks new SSD is too small.

Have cloned successfully 3 other drives to new Crucial SSDs with no problems. I’m assuming this error may be due to the APFS format?

Help much appreciated.


Edit 1

I have now erased the SSD (appears as ‘ASMT 2115 Media’ ) from scratch, name ‘Aidan SSD’, Format MAC OS extended (journaled), scheme GUID partition map.

What I now notice is that the new volume/partition is 499.76GB, whereas the hard-drive Macintosh HD is 499.99GB.

Is this the cause of the error on restore? How do I format the new SDD to have 499.99GB?

Edit 2

Solved. Erased and created new APFS volume directly, not by creating OS Extended Journalled first (this is then changed on Restore to APFS but retains smaller size). Creates as 499.99 GB needed and restore now running.
2 Replies
Bit Baby

Re: OSStatus 28 Error on Restore Mac Mojave APFS

I'm having the same error. Can you clarify in exaclty what steps you made to fix the error and during what part of the process?


Re: OSStatus 28 Error on Restore Mac Mojave APFS

@Ralph45 I think @SteveWUK had to create a GUID APFS volume on the new SSD before using Disk Utility to restore the drive.  I would suggest you use Carbon Copy Cloner (CCC) instead of Disk Utility as CCC will also recreate the hidden Recovery Partition for you.  I've had trouble using Disk Utility to create bootable clones sometimes so now I always use CCC. 


Another good option is to do a clean install of macOS on the new SSD, then use Migration Assistant on the first boot to transfer your User Folder(s), data, settings and even apps to the new SSD.  With this option, you will need to reapply any proprietary license keys for MS Office, etc.  as they don't seem to transfer.  If OSX 10.12.4 or newer has already been installed on this system, then you should be able to boot into Internet Recovery Mode to install the OS without needing a boot disk.