Problem with MSATA M500 (Drive Locked)

Kilobyte Kid

Problem with MSATA M500 (Drive Locked)

Good afternoon, I write to ask them for help with an SSD unit that was given to me. 1. I connected the unit to my latop (Dell E7240) and since it turns on it tells me that my SSD is protected by password.

 

2. I tried to install all the possible operating systems but it has not been possible for me, it always tells me that I can not format the SSD.

 

3. I have started an Ubuntu Live CD, it detects the SSD, but it does not allow me to format it.

 

 

 

4. I installed Ubuntu on a USB drive, I installed the Micron Storage Executive application, but when trying to enter from http: // localhost: 8080 / storageexecutive / gui / sysinfo does not load anything. I have also tried to run it from Linux but I can not find the option.

 

I am a basic-intermediate user, any kind of help that you can give me will be well received. Thank you.

 

 

 

Tags (1)
1 Reply
Highlighted
JEDEC Jedi

Re: Problem with MSATA M500 (Drive Locked)

Your screenshots haven't been approved by the moderators yet, but it sounds like the Dell BIOS is prompting you for a password to unlock the SSD.  If this is the case, then the SSD is most likely protected by a BIOS hard drive password which uses the ATA Security feature of the SSD in which case the SSD is a brick unless the original owner provides you with the password(s) or disables it for you.  You can verify if this is the case by running the following command from a Linux terminal (make sure to substitute the "X" with the correct drive identifier for the SSD):

sudo  hdparm  -I  /dev/sdX  |  grep  -i  ^security  -A8

If you see the following in the output:

		enabled
		locked

then the drive has ATA Security enabled and you will need to acquire the password from the former owner of the SSD.  If the Dell BIOS won't allow you to disable the security with the password, you could try using Linux to disable it.  You may need the original owner to reinstall the SSD into their computer in order to disable the password using their BIOS as some BIOS manipulate the password before saving it to the SSD. 

 

If you see:

	not	enabled
	not	locked

then ATA Security is not enabled and we will need to check other things.