Remove 'Micron Firmware Update' from BIOS

SOLVED
Highlighted
Kilobyte Kid

Remove 'Micron Firmware Update' from BIOS

Hi,

 

I have a 'Micron Firmware Update' listed in the bios boot options, how can I remove this from the list?

 

I have a Ivy Bridge desktop PC with a 512gb MX100.

I have previously updated the MX100 firmware.

The  'Micron Firmware Update' remains as an option when all drives are disconnected.

 

Thanks.

4 Replies
Kilobyte Kid

Re: Remove 'Micron Firmware Update' from BIOS

The only way I could do it was to do DiskPart Clean operation on the drive before reinstalling Windows from scratch. If you're going to install Windows 10, now might be a good time to try this. It is also necessary if you want to get H/W encryption going via Opal 2.0, so you can get everything covered in one go if you're canny.

Kilobyte Kid

Re: Remove 'Micron Firmware Update' from BIOS

 

Hi, unfortunately DiskPart Clean did not work for me.

 

I had to reflash the motherboard firmware (uefi/bios) in DOS. I also had to use the /C switch to clear the DMI during the flash.

 

Example.

1) I used a program called Rufus to create a FreeDOS bootable USB drive.

2) Copied the efiflash.exe program and bios.bin file to the usb drive.

3) Booted to FreeDOS and at the prompt entered the command...

 

efiflash.exe bios.bin /c

 

'Micron Firmware Update' is no longer available as a bootable option in the bios. 

 

Thanks

Kilobyte Kid

Re: Remove 'Micron Firmware Update' from BIOS

Wow, really? Are you sure clearing the CMOS with the jumper on the motherboard (after a Diskpart Clean) or just doing a firmware reset to default settings (again, after a Diskpart Clean) wouldn't deal with this (I assume you tried those first)? Seems pretty extreme to have to reflash your motherboard firmware, and that would be a poorly designed motherboard firmware to blame as well as Cruical's flawed flash process that leaves the junk there in the first place. You were unlucky to have both companies team up on you with this one.

Kilobyte Kid

Re: Remove 'Micron Firmware Update' from BIOS

Yep, tried lots of stuff.

 

SSD = CT512MX100SSD FW:MU01 on label, updated to MU02.
Motherboard = Gigabyte Sniper M3.

 

The MX100 had caused some BSOD errors.
One that stopped windows from booting and caused a boot loop to 'Micron Firmware Update'.

 

eg.
Boot
Micron Storage Executive.. Loading.. fdisk device has more than 2^32 sectors, cant use all of them.
Invalid firmware directory specified with -i option.
Reboot.

 

Here is a list of what I tried to (A) get windows to boot and (B) remove 'Micron Firmware Update' from the bios.

(not necessarily in order).

 

Disconnected all drives from motherboard.
Format c: /FS:fat32 /v:system /q
bootrec /fixboot
bcdboot D:/windows /l en-us /s C: /f ALL
bcdedit /enum firmware
bcdedit /import
EasyBCD to check and read boot config on EFI System partition.
scandisk
SFC /scannow
Realise it would be quicker to reinstall Windows.
Diskpart clean
Reinstalled Windows in MBR mode (not UEFI mode).
Reset motherboard firmware to optimised defaults.
Loaded known good custom motherboard settings from backup.
Cleared CMOS with jumper on motherboard.
Removed motherboard battery overnight.
Flashed motherboard firmware with 'Q-Flash' embedded flash utility.

 

Flash in DOS mode with efiflash.exe bios.bin /c
Its always the last thing you try that fixes the problem. Smiley Happy