Storage Executive 3.55 Windows 10 Problem

Kilobyte Kid

Storage Executive 3.55 Windows 10 Problem

When I first tried to upgrade from Storage Executive 3.50 it would complete the install but on the reboot Windows 10 version 1803 would just before the login remove the gui.jar file from C:\\Program Files;Crucial;Crucial Storage Executive;Lib directory. I then tried removing 3.50 through programs and features and I had the SE 3.55 file I downloaded and tried an install and it completed but again on the reboot did the samething. On either one without this file once in Windows I could not go into SE. And this was about two weeks ago or so. In the mean time I had an SE 3.46 downloaded file, but not the SE 3.50 so I loaded the 3.46 and everything worked once again with Momentum Cache activated. 


Then there was a Windows 10 version 1803 update and I also did some driver updates. After these updates I tried an update on SE 3.46 to the new SE 3.55 and it downloaded and after the launch said that I was on 3.46 and it didn't update. I then removed the SE 3.46 and from the SE 3.55 file ran that and it installed and after rebooting it did not remove the gui.jar file and I was able to login into Windows. I then went into SE and it came up and I went to About and it was on the 3.55 and I activeated Momentum Cache and it rebooted with no problems and MC was turned on. I'm assuming that the Windows 10-1803 update fixed whatever the problem windows saw with this gui.jar file. 


I did some testing to see what results I would get with Anvill Pro and AS SSD Benchmark with Momentum Cache Off and On. Below are the results and as you can see the Momentum Cache makes a big difference. Just so you know I have a Dell XPS 8920, i7-7700 CPU, 16 Gig Ram, and a MX300 SSD.


Anvil Pro without Momentum Cache

Read- 1,406     Write- 942      Total- 2,348

Anvil Pro with Momentum Cache

Read- 1,421     Write- 9,410    Total- 10,831


AS SSD Benchmark without Momentum Cache

Read- 274       Write- 149        Total-570

AS SSD Benchmark with Momentum Cache

Read-11,655    Write-1,248      Total- 18,739


4 Replies
Bit Baby

Re: Storage Executive 3.55 Windows 10 Problem

I was using Storage Executive 3.50 with Windows 10 v1803 (latest and fully updated) and was working fine. After updating to v3.55, Storage Executive doesn´t start anymore and get 2 erros seen in the images below. Java is enabled and also with latest update installed. No way to reinstall trying to fix the error. With v3.50 was everything working fine.

How can I fix it?



Captura de Tela (84).pngCaptura de Tela (85).png 

Kilobyte Kid

Re: Storage Executive 3.55 Windows 10 Problem



If you haven't tried removing SE3.55 by Programs & Features and then running the SE3.55 executive file, you might give that a try. Then of course if this doesn't work and you don't get any other help you could go back to SE3.50, if you have the executive file or an earlier version file for the time being until you can get a resolution. I know on my computer I don't like running without momentum cache in any version of SE. 


Kilobyte Kid

Re: Storage Executive 3.55 Windows 10 Problem

When I try to update it, it says it tried to downgrade to 3.46 but failed and I'm on 3.50.Updating.PNG

Crucial Employee

Re: Storage Executive 3.55 Windows 10 Problem

@Redbatman please make sure you've completely uninstalled your current Storage Executive install and downloaded the latest version to install. Please let me know if this doesn't do the trick.

Crucial_Benny, Micron CPG Support, US

How do I know what memory to buy?
Shop for your region: US | UK | EU | France |
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?