Trying to erase SSD

Bit Baby

Trying to erase SSD



I just sold my desktop computer and I have to ship it today. I have been trying to erase my SSD so my personal information will be gone. I am on windows 10 and my SSD is a 275GB Crucial MX300.


I tried using parted magic but it said my SSD was unsupported. So then I went into the storage executive and it won't let me sanatize or PSID revert my SSD. I keep getting an error saying "Drive has mounted partitions". What is a mounted partition? 


Should I remove the drive letter? This SSD is my boot drive, so is that a problem? 


I thought the problem was my system not being in AHCI mode. But it is. 


If anyone can help me out, I would greatly appreciate it. 


Thank you,



2 Replies
Bit Baby

Re: Trying to erase SSD



I actually just loaded my windows boot media into the computer, and now I have a fresh copy of windows installed and my information is gone. I formatted the drive. 


I think I solved the problem unless there is something else I should know. 


Thank you


Re: Trying to erase SSD

Glad you're sorted. Just so you know for next time, Storage Exec cannot erase the OS you are running from.  The drive would need connected as a secondary drive to another Windows install.

How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?