Why did my SSD "disappear" from my system?

Community Manager Community Manager
Labels (1)

A sudden power loss or rare software events can cause a system to fail to recognize an SSD, or not detect one it was previously able to. In most cases, your SSD can be returned to normal operating condition by completing a power cycle, a process detailed below which will take a few minutes, followed by optimizing your power settings for SSD use. This process is non-destructive, and your data will be intact as long as whatever event triggering the SSD malfunction did not affect your file system as well.


Apple and Windows desktop users follow the same steps.

1. If possible, connect the SSD via a hard drive enclosure or USB-to-SATA adapter, then plug it in to a USB port (preferably a different system if possible, to rule out system-level malfunctions). Whether the drive is visible or not, let it sit in this state for a minimum of five minutes to allow the SSD to rebuild its mapping tables, then reboot the system and see if the drive is restored.


2. If a USB adapter is not available, reseat the drive and boot in to your system’s BIOS or UEFI with the drive connected normally for a minimum of five minutes to allow the drive to attempt this same rebuild, then reboot the system and see if the drive is restored.


  • Note that this mode may be less effective than a USB connection, as some systems will cut power to an attached device if the drive does not mount normally.


3. If the above steps do not help, try the SSD in another system (if you haven’t already), to rule out the original cabling and ports as a potential cause of this behavior.


4. If the drive comes back and is functional, it is recommended to update the firmware to the latest revision (if applicable). The page with the latest firmware revisions can be found here.


5. If this procedure does not resolve the issue, a replacement may be needed. Please contact us for more assistance.

Kilobyte Kid

nice recommendation - BUT i would return such a drive: You can't reliably use it in a server i you newer know if that could happen again

Kilobyte Kid

i had this happen i did the 20mins 2 times the sdd was bricked this does not work at least for me m4 512gb my drive just died

and will not come back to life

Kilobyte Kid

My 512GB m4 SSD was disconnecting once an hour and it turned out to be a bug in the early m4 firmware. A firmware update fixed it. Too bad it was the last thing I tried. IMHO, if you have an m4 SSD that's about 4-5 months old that disconnects a lot, try the firmware update first.


Note there is a bug in the 000F m4 firmware that causes constant beachballs on Macs. If you have a Mac, then use firmware 0309 or else whatever is released after 000F.

Kilobyte Kid

For my M4 on 0309 {000F is lower performance} it's don't resolved this issue.


only 1300 hours...

Kilobyte Kid

The suggested fix did not work for my M4 512GB, firmware 000F, it remains bricked after less than 200 hours of use. Very annoying - I'm on a business trip with my laptop right now and have no way to replace the drive and install it from scratch until I return.


Any more suggestions to things I might  try?


Also, I'm interested why the proposed procedure should do anything in the first place. Is there some magic in the drive logic that attempts a repair when its powered on but not accessed for 20 minutes?



Kilobyte Kid

I have 6 ssds on 6 machines. This happened on two of them in one week.  This fix worked for me.  I'm updating the firmware in all my pcs... 

Kilobyte Kid

I installed my M4 yesterday. I restarted my desktop a few times because of installation processes, and turned it off when I wasn't home.


Today when I restarted it after installing sound driver it said I had to choose a proper Boot device. For some reason my M4 is not being recognized.


I tried this solution but it didnt work for me... I don't know if I did right, because this is the only SSD with windows installed, my other HDD500GB is acting as a secondary... So I left it on the "select proper Boot device" for the 20 minutes, is that right?




Moderator Moderator



The boot device selection screen works just as well as booting into BIOS, so yes, leaving your computer on that screen should have worked.


If you did that twice for 20 minutes, and disconnected the SSD for at least 30 seconds after each 20 minute strech, and the SSD still is not recognized, I would recommend that you contact Customer Service for your region, for more indepth troubleshooting.

Bit Baby

My 64G M4 disappeared last week. I've gone through several power cycles with disconnections, it is still not seen by my BIOS. However, when I purchased it I got the kit with USB connector and transfer software. I installed a new SSD, loaded W7, then connected the M4 via USB cable. The EZGIG software can see my drive (asked me to format it, I declined for now). It appears the drive is functional via USB  I reconnected the drive to a known good SATA connector and power cable, the BIOS is still not seeing the drive. I would really like to get this thing working in order to get my configured OS and programs back and save the headache of configuring a new system.


What else do you recommend to get the drive working again?

Moderator Moderator

If your computer sees the drive when you connect it with the SATA-to-USB cable, then this power cycle process may not change the situation you have with your SSD. I would suggest that you contact Technical Support for your region at this point. They can assist you with further troubleshooting, and if necessary they would also be able to help with an RMA.

Kilobyte Kid

I have used a 60 Gb Crucial M4 as my boot drive in one PC for about a year, and I had never encountered the problem described above until a couple of days ago when a driver barfed, and I had to shutdown my PC.  After this occurred, the Crucial SSD would disappear about 5-15 minutes after startup.  If you restart your PC, the drive still won't reappear - the PC has to be cold-booted (powered down and restarted) for the drive to appear.  I tried the power on/off procedure above several times, but it resolved nothing.  Fortunately, I just downloaded the Rev H software and updated the firmware.  After a few reboots, the problem appears to be resolved.  Hooray!  Good luck to those of you who still have the problem.

Bit Baby

This was the main drive in my laptop, and I was so freaked out it disappeared!  I was using my laptop when the whole thing hard locked in Windows 7.  I poked at it a bit, but eventually had to hold down the power button to force it off.  Then on the reboot, the BIOS complained there was no hard drive!


I forget how I found this page, but I have a Thermaltake BlacX5G USB3 to SATA adapter, which has AC power, so I used that to power the drive (leaving the USB completely unplugged).  And for the 30 seconds unplugged, I removed it completely from the adapter.


After the second 20 minutes, I pulled the drive, waited 30 seconds, then plugged the drive back in and plugged the USB into another computer, hoping it would mount at that point, but it never did.  I was crestfallen, but I put the SSD back into the laptop, thinking I'd follow the instructions regarding waiting in the BIOS, but when I turned on the laptop, it found the drive, and boot back into Windows!!!


I immediately backed up the important files, and am now looking into determining the firmware (and presumably updating it to the latest).

Moderator Moderator

I'm sorry you ran into issues with your SSD, but I'm happy to hear the power cycle process worked and that you're back up and running now.


If you are interested, we have another article that has directions on how to determine your firmware version, and the latest firmware can be found here.

Bit Baby

Hope this will help anyone.


I run into the same issue and even serveral times having the computer idle for about 20 minutes and than disconnecting the power did not help. Usually I did get a blue screen after just a few minutes.


Using a Crucial M4 120GB on a Gigabyte MB (Exact model currently not at hand) and had the SSD on SATA channel 0, DVD drive on SATA channel 1 and another HD on channel 4.


All issues seem to have been gone since I changed the DVD drive to channel 2.

Bit Baby

Firmware 07MH doesn't work.  My laptop ASUS B121 still hung every once a while and

the  BIOS cannot detect it after suspension.  I call custom service here in Taiwan but no one

answer the phone.  The agency said it is not their business and tell me to go to Asus.

Moderator Moderator

Hello jpntw,


I am sorry to hear that you're having issues with your SSD.


We do not have a customer service center located in Taiwan, but you are welcome to contact our US Customer Service. They will be happy to assist with troubleshooting, and if you need to do an RMA, they would handle that for you as well. Be sure to let them know what troubleshooting steps you have already taken on your own, to make it easier for them to assist you. Smiley Happy

Kilobyte Kid

Tryed it didn't work. 

I'm trying to reach support for 3 hours. 

I'm about to go balistic ! 

Bit Baby



Worked for me! Did the cycle three times.


Thanks a lot

Community Manager Community Manager
Community Manager

Hi Lanjan,


I am glad that your issue has been fixed! Let us know if there is anything else we can help you with.

Bit Baby

Same problem as everyone else…. M4 worked great for 18 months and then gave up the ghost. I took it out of my Dell E6230 and hooked the drive up to the Crucial USB transfer cable I used to copy my hard drive to the SSD during initial installation. I then plugged the USB end into a standard USB (phone) charger.  I did two cycles of the power on for 20 minutes and power off for 30 seconds (or so) by disconnecting the USB charger and then put the SSD back into the Dell and it worked good as new.  I have also modified the power plan for the Windows 8 system to keep power to the drive at all times. Check back with me in another 18 months…

Bit Baby

I just recently swapped out my M4 for a new MX100. I shut down the system, unplugged the M4, installed the MX100 and installed Windows 8.1, then plugged in the M4 to get my data off it. Nothing.  System wouldn't recognize it. I have tried everything and the REALLY frustrating part is that I unplugged the drive EXACTLY 3 years to the day of purchase (September 27th, 2011). They won't cover the three year warranty even though I tried to submit an RMA on Saturday the 27th. Arghhhh !!!



Community Manager Community Manager
Community Manager
Hi John. We are really sorry for the issues that you have experienced with your drive. Even if the warranty has expired we still offer free tech support. Please call us directly and we would be happy to see if there is any troubleshooting we can attempt. Our number is 1-800-336-8915. I am sorry for the inconvenience.
Bit Baby

All I can say is no fargin way.  Tried just about every trick in my book.  Even tried the baking thing as stupid as it sounds - hey, I was desparate.  Then, I followed the instructions here and, voila.  SSD saved.  These instructions sound like total BS, but it worked like a charm for me.  Thank you Crucial.

Kilobyte Kid

My mx100 512gb cannot be detected on bios or uefi after my Dell Inspiron i3531 Windows 8.1 prompted that "your pc ran into problem ..."

I tried to power cycle 5 times (connect/reconnect as per crucial's instruction) on three laptops (one has core duo CPU) but to no avail. I even tried to power cycle 5 times via a usb to sata power cable.

Nothing works. Did I do the power cycle correctly? Could please you post a video to show what is the correct way to power cycle?

I am getting a Mac mini soon. Would a Mac be able to recognize mx100 more easily? Please help

Kilobyte Kid

hi to all, im Bruno from Argentina and i have a Crucial M500 240gb since march 2014...


since i have the ssd, i guess 4 or 5 times the system freezes, and restart... after restart the ssd was not detected anymore... reconnecting sata and power cables a few times bring the ssd back to be detected... the last time i had this isssue was yesterday, after that i decide to contact crucial support to prevent this happening again... i explain to this nice agent my problem, and told me to do a power cycle and then update the firmware...


ok, i did the power cycle, and then it wasnt able anymore to start windows... after the first screen (the one who describe the computer processor, ram, etc) it says "loading operating system"... and restart.... over and over again.... the crucial was detected in the first creen, but it dont start windows...


i try to reinstall windows, with the dvd... but i wasnt able to do it... 

i connect an hdd with windows as master drive, then the ssd as a slave ( changing bios settings to have the hdd as primary boot drive) it take 10 minutes to pass trough STARTING WINDOWS screen.... then i could see the ssd in "my computer" but cant acces him... and in the disk manager it shows the 100mb partition for windows as RAW, and the rest 2xxGb as BASIC... i try to format, delete, etc, and no response....


so thats my issue... i just chat with another agent that told me to make an ACTIVE GARBAGE COLECTION, so i have to wait 8hs to see if the problem is solved or not...


meanwhile any advise its well recived =)


**bleep**: sorry for my english, i hope i can make all understand me...



thanks for all,




Kilobyte Kid

I have one Crucial m4 32GB mSATA Internal Solid State Drive CT032M4SSD3, purchesed on amazon on 11/15/2013 instaled on my Intel NUC. 


This week I got this message: A bootable device has not been detected.


My ssd disapper from my BIOS and I find this article and try 2 times power cycle my ssd, but with no luck. I use the notebook process on my Intel NUC.


If I remove power cord from my NUC my sdd reaper in BIOS and my OS start with no problems, but if I reboot or shutdown, my sdd again disapper from my BIOS. The only way to ssd work is remove my power cord, wait for 5 seconds, replug, and power on my nuc, but this is very annoying.


My ssd have the lasted firmware version: 07MH


Please, can someone can help to resolve my problem?


Moderator Moderator

I'm sorry to hear the SSD is not working as expected.


It sounds as if the issues are related to power management of the SSD port. If that is the case, you will want to look at the power savings options in your BIOS. Make sure they are set to not power off the drive during idle times, in other words, you want the SSD to have full power at all times. You may also want to check and make sure that you have the latest BIOS on your NUC.


If you are still running into difficulties after making the changes to your power management settings, please contact Technical Support directly for more in-depth troubleshooting.

Bit Baby

1.      Once you have the drive connected and sitting idle, simply power on the computer and wait for 20 minutes. We recommend that you don't use the computer during this process.

2.      Power the computer down and disconnect the drive from the power connector for 30 seconds.

3.      Reconnect the drive, and repeat steps 1 and 2 one more time.

4.      Reconnect the drive normally, and boot the computer to your operating system.



Worked like a  charm, thank you!

Kilobyte Kid

Hi, MY Crucial SSD Died some time back,  ( Model 256GB  m4 ssd 2.5) , i have tried all the above options, but not able to get it working, One thing i would like to point out is, when connected to PC thru Powered USB, i can see the partition , but not able to access , once i could see the folders inside the drive. But now, it shows as RAW drive only.

Anything i can do to revive this drive ? I need to retrive some data.

Kilobyte Kid

Hi everyone,


very documented topic, however, I'm running into a problem that's not quite covered here or partially, this why I allow my self to ask you guys.

Macbook Pro 5,4 (mid2009-2.53GHZ), I replace the former HDD with a M4 256 frmw 000F.

One day it went ghost, either way in and out the Mac... I'm just about to proceed to a power cycle.

Question is:

If not sitting in the Laptop and if not using a USB enclosure powered via USB, quid of the connexion. I have a Sata to USB cable with one for the DATA and one for the power.

Thank you for reading and taking time,


A Used to be a user willing to be again 1



Kilobyte Kid

Hi everyone,


I just want to share my story wicht started with similar symptom: an ssd (evo850) just disappeared on my laptop (ux32l) and after reboot I was kept getting into bios, where I had no boot devices. I remove this ssd from the laptop and put it into an external box for hdd and it worked just fine through usb. So the problem was not with the ssd and I put it back into the laptop. But still bios didn't show it in the boot tab.

So I decided to boot from some usb flash with Windows installation on it. It worked and installation started from flash, but since I didn't want to reinstall my system, I rebooted the laptop and removed this usb flash, and a miracle happened, the laptop booted from ssd and keeps working ever since. And that's it my happy ending story Smiley Happy

Kilobyte Kid

The drive in my daughters computer mysteriously disappeared yesterday, I followed this guide with the drive in the PC, but still the drive did not work. Last night I'd left it plugged into my USB drive caddy, turned my PC on tonight and the drive just appeared. So I quickly backed it up, then put it back in the original PC and it booted just fine. I checked the firmware and it was quite an old version 01G or something like that so I updated it. Hopefully now it will be fine.

Bit Baby

This was the solution to my problem. Thanks!

Bit Baby

I am now having the same problem as everyone else. I've tried the powering up and down option but still not finding it. I am going to buy a drive usb adapter and see if my computer can find it that way. I would not recommend crucial again after this because it appears to be a common problem with the M4 model and what crucial as a company should have done was a replacement option or provided a free service for a Best Buy to have to go through the trouble of fixing it. The panic of losing your entire computer due to a faulty drive is the worse feeling a user could go through. Very unhappy.

Bit Baby

Fixed !!    I just had a 120 gig M500 drive not be recognized on HP Pavillion DV7 laptop after power outage from a storm, I rebooted couple times and no luck, drive was not being recognized, came here and read previous comments and tried again doing reboot but this time i unplugged ac power cord and unplugged battery for about a minute first, then i left ac power unplugged and rebooted and went into bios by hitting esc key on bootup and bios saw the drive, i then had bios do a error check on drive and all went ok, so i saved bios results and rebooted again only on battery power , no ac plugged in , and win 10 saw the drive !!    All good, i did a fresh backup of drive in case this acts up again and it backed up with no errors. I then plugged ac power cord back in and still good. First time this has ever happened and i have 4 ss drives in 2 machines. Hope this helps.