Why doesn't my desktop recognize my SSD?

Community Manager Community Manager
Labels (1)

Follow these steps if you are having issues with your desktop's SSD recognition:

 

  1. If the drive is being added as a secondary storage device, it must be initialized first (Windows, OS X). If not, disregard this step.
  2. Remove, reseat, and double check the connections (both the narrow data connection, and the wider power connection from your system's power supply)
  3. If your SSD is installed externally (or internally using a drive bay or enclosure) try plugging the SSD into the SATA port directly using a SATA cable.
  4. If that does not work, try a different SATA cable. Plug the cable into a different color SATA port on the motherboard.
  5. Make sure the old drive still works. If not, go reinstall with the old drive, checking all connections
  6. If the old drive still works,  but the new SSD does not, try it in a different system if possible.
  7. If the drive does not work in any system or connection, try a power cycle on the drive, and if the drive still does not work, a replacement may be needed.
  8. If the drive works in a different system, update to the latest firmware and try in your desktop again
  9. Check to make sure your system has the latest BIOS installed.
Comments
Titantula
Kilobyte Kid

I have a MX500 and it worked for the first two months. Then I got a blue screen crash. Upon reboot I tried to recover my windows installation from my SSD but it would not recover or repair. After putting in my old HDD drive and installing windows to that I was able to boot. However....

 

My SSD drive doesnt shown in my bios, it doesnt show in Disk Management and is missing from Device Manager. Upon playing around trying to fix this I discover it was showing as a USB drive on the `This PC` window. If I try to explore it I get told to insert a disk into the USB drive. I cannot format it. In device manager is shows as a USB drive in the Disk Drives section. I have also tried connecting it to a different SATA 3 port with the same problems.

 

There is juice going into it and the computer is detecting it, but it thinks its a USB drive! It also doesnt show in Crucial Storage Executive and Acronis wont run as it wont detect a SSD drive in my system. Please can I ask if there is a way to resolve all of this?