mac mini el capitan Crucial ssd fails to install

Kilobyte Kid

mac mini el capitan Crucial ssd fails to install

Mac mini late 2009, El Capitan 10.11.6

Crucial CT500MX500SSD1Z.PK01


SSD formats and mounts correctly with USB to SATA cable... can read and write to it


Start up into Disc Utilities according to instructions

Select SSD apple partition and the Edit/Restore as per instructions


Retore process starts but after a few minutes the following error message is displayed:



/sbin/newfs_hfs failed with error 256

Could not restore - Device not configured 

operation failed


Any ideas / help?





4 Replies

Re: mac mini el capitan Crucial ssd fails to install

I would recommend using Carbon Copy Cloaner to clone the original drive as it will also provide a copy of the Recovery Partition as well and is much more reliable than using Disk Utility.


Another good option is to perform a clean install on the new SSD.   Since your first attempt at a clone failed, I would suggest Erasing the new SSD again using Disk Utility.  You can boot into the Recovery partition on your original drive by Option booting.     There should be an option to (re)install OSX, just make sure to select the new volume on your new SSD as the destination.    When you first boot into the new OS, it will ask you if you want to perform a migration, select it and it can migrate your User folder(s), settings, and even Applications.   The only downside to this method over using Carbon Copy Cloner is that some proprietary software licenses (MS Office, Adobe, etc.) will need to be reactivated.


If you don't have a Recovery partition on your drive, then see if you can download the installer from the App Store again.   I think you should be able to initiate the install from your old drive or you can search online for instructions on creating a bootable USB installer for it.

Kilobyte Kid

Re: mac mini el capitan Crucial ssd fails to install

Thanks but...


All methods failed including the carbon copy application.


Just to eliminate other problems I grabbed an old 160GB Windows Vista/Linux disc I had laying around, formatted it as Mac then used the Option Boot method you described and the install went fine.


It seems that the Crucial disc (once it has been written to during the install process is 'ejected' and then can't be written to or found as the process continues.


I also tried the Apple method of downloading the 6.22 GB bootable install file and then placing it on a USB stick-- no problem, but it would crash the SSD disk whenever I tried to place it on that SSD.


My hardware and software seems to be performing correctly since the install went ok on the old SATA HD so I think I'm out of options here other than returning it.


Your thoughts?


Re: mac mini el capitan Crucial ssd fails to install

Try installing OSX onto the SSD while it is connected externally if you haven't done so yet.


If you are concerned about what might be left behind obstructing the install from the previously aborted clones & installation attempts (a valid concern), then you should open a Terminal & "dd" zeroes to the beginning of the drive (or a Secure Erase while the SSD is installed internal to the Mini using Linux or PartEd Magic).   Then while running the installer, you should be able to launch Disk Utility and partition the blank SSD and continue with the install.   If you cannot install OSX while the SSD is connected externally, then do you have another system you could install or connect it and try installing an OS?   You could also check the SMART attributes on the SSD and post a screenshot here.   Use the USB flash drive or your fresh install on your old Win/Linux hard drive so to eliminate any issues with the Mini's original drive.

Kilobyte Kid

Re: mac mini el capitan Crucial ssd fails to install

Thanks for the help.

I had been trying an external install using two different computers (both late 2009 macs)


Tried zeroing out the drive on Windows 10... seemed to wipe it, reformatted on mac as mac partition but still had the same problems whe trying to install OS El Capitan.


Frusterated I returned it for another identical drive. The second drive installed and worked right away so I suspect the original one had a problem of some sorts.


Original problem drive identity started with a C.... didn't write it down.

Replacement drive identifies as ASTM  ASM105x if that might help you in the future.