Asus X556 (F556U) Running Ubuntu - New Memory, Laptop Won't Boot

Kilobyte Kid

Asus X556 (F556U) Running Ubuntu - New Memory, Laptop Won't Boot



I purchased an 8GB memory stick to supplement the existing memory on my Asus F556U laptop after running my laptop type through Crucial's matching system. I purchased the recommended stick (below) and installed it into the auxilary memory module on the laptop. When I went to turn the laptop on post-installation, I heard the fan kick on and the screen flickered, but it stayed on a black screen (no BIOS menu, no normal boot screen - nothing, just black). I turned the laptop off and removed the new memory stick and restarted the computer and everything worked fine as before.


I've tried this process multiple times now under a range of circumstances (laptop fully charged, making sure the RAM stick is inserted firmly, etc) and I get the same outcome - a black screen with no additional troubleshooting options at my disposal. I found a few older posts addressing this issue but with no apparent resolution, and the direction it seemed to be going was that either the new sticks were defective or there was an issue with BIOS on the computer. I updated my BIOS 7 months ago when I whiped Windows and did a full Ubuntu install, so I don't think this is the issue.


The other kicker is that I'm running Ubuntu 16.04 LTS (most of the existing posts appeared to be geared towards Windows systems) and I have a recently set-up Windows 10 virtual machine (in VirtualBox) that is partitioned to use half of my existing memory and 50 GB of HD. My initial instinct was to uninstall the virutal machine to free up my memory troubleshooting options, but it doesn't seem like that is the issue given other people have experienced similar symptoms with a clean Windows install. 


So the question is: do I have a bad stick that I need to return/replace, is there a better hardware option than what I purchased, or is there a special Linux procedure I need to be following?


Hardware specs:


The memory I purchased is: 

Crucial 8GB DDR4-2400 SODIMM CT8G4SFD824A


Laptop Specs:

Ubuntu 16.04 LTS with Windows 10 VM

Asus F556UA-AB32, Core i3-6100U 2.3 GHz Processor, 4GB DDRDL RAM, 1 TB 5400 RPM HDD




Tags (4)
1 Reply

Re: Asus X556 (F556U) Running Ubuntu - New Memory, Laptop Won't Boot

Assuming I found the correct model on the Asus website the last BIOS firmware update is listed as v408 from just a couple weeks ago.  You should be able to update the BIOS by putting the firmware file on a FAT formatted USB drive and entering the BIOS and selecting Easy Flash under the Advanced menu.  They also recommend resetting the BIOS to defaults after the update.  See page 75 (English) User Guide here.


As far as the black screen, this has nothing to do with Linux since the system never even displays the POST.


Have you tried removing the original RAM and just trying the new RAM by itself?  Try it in the slot occupied by the original RAM as well to make sure the auxillary slot isn't bad.  Try resetting the BIOS to defaults.   


Looking at the User Guide, it appears Asus doesn't have you disconnect the battery when installing the memory upgrade probably because it is difficult to access.  I don't like that, but not much we can do about that unless you feel adventurous and are willing to risk damaging the hidden plastic latches securing the cases which even experts can break.  Sometimes disconnecting all power sources including the battery & the CMOS battery can reset & "fix" things.  It is a longshot.


If trying the new RAM by itself in the slot where the original RAM was installed doesn't work and the firmware update with BIOS reset doesn't help, then you may want to try exchanging it as there is a slim chance you received a defective module (I cannot even remember the last time this happened to me) or maybe there is an issue with your laptop..