Cannot Boot Acer Aspire M5800 after installing new RAM

Kilobyte Kid

Cannot Boot Acer Aspire M5800 after installing new RAM

I purchased a 4GB kit (CT2CP25664BA1339) for my Acer Aspire M5800 desktop to replace the original 2GB.  When I install the memory the computer will not boot.  All I get is a loud buzzer and a black screen.  I have tried each module individually in the same slot as the original RAM as well as in other slots, separately and in combination with the old RAM.  Always the same result.

I contacted support via chat and was told to update the bios, but I've checked, and I have the latest version (P01-A2).

I have also been careful to make sure the modules are properly seated.

The person on chat support assured me this is the correct memory.


What to do?

1 Reply
Community Manager

Re: Cannot Boot Acer Aspire M5800 after installing new RAM

Hi LesIsmore,


I'm sorry to hear that you are having problems with your memory upgrade.


I have had a look in to this system for you and the memory you have ordered is unfortunately not compatible with that system.  The memory you have ordered is the standard 8 chip high density memory, however that system needs the 16 chip low density memory for it to work.


If you ordered the memory direct from us we would be more than happy to arrange an exchange for you, just contact the customer service team HERE.


If you ordered from another supplier you will need to return the memory and order part number CT2KIT25664BA1339A, or you can order the part direct from Crucial HERE.



Crucial_Junket, Crucial Moderator, UK

How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?