upgrade in memory not recognised

Bit Baby

upgrade in memory not recognised

I have just installed a 1 GB upgrade to my fujitsu siemens amilo Li1718, as recommended by Crucial. Laptop has two slots and each was occupied by 512mb of memory, therefore I removed one and put in the new 1GB one as extra, however when I check on the system properties it is still showing only a max of 1024mb and is no faster at all. I tried the new one in both slots but no joy. When I did a similar exercise with my desktop it improved things a lot. Grateful if anyone can help but note I will need a simple explanation! Thanks..

3 Replies
Moderator

Re: upgrade in memory not recognised

 

Hi Robin,

 

Have you tried the new module on it's own in the system?  If so, how much is recognised? 

 

This system actually has a chipset limitation whereby it can support both high and low density modules, however the two types cannot be mixed.  The 1GB module we sent should have 8x 1Gb (gigabit) chips on it making it high density and it sounds like your original 512MB module has 8x 512Mb (megabit) chips making it low density.  You can check the modules to confirm this.

If this is the case then you have to match densities so you can either remove the 512MB and get another 1GB module to go to the maximum 2GB or try to source a 16 chip 1GB module to use alongside your 512MB.  Unfortunately we no longer supply that revision.

 

I hope this helps, please let us know if you require further support.

 

 

Maulmod, Crucial Moderator UK
________________________________________

How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Kilobyte Kid

Re: upgrade in memory not recognised

I've just installed two identical 1GB modules in my Amilo Li 1718 and in system info it displays RAM as only 1534MB, should it not register 2000MB?

Kilobyte Kid

Re: upgrade in memory not recognised

It's now showing as 1918MB, after powering up this morning.  It's also dealing with video editing software much more swiftly than before.