256GB m4 mSATA SSD Works in M6500 (... SORT OF)

Kilobyte Kid

256GB m4 mSATA SSD Works in M6500 (... SORT OF)

Before this week, my quad core M6500 was running on a 256GB RealSSD C300 as the only drive.  In search of the ideal setup for a SQL workhorse (i.e. separate spindles for the OS, Data and Log files), I purchased a 512GB m4 2.5-inch SSD and the recently released 256GB m4 mSATA SSD.  My plan was to clone the system image from the C300 to the mSATA and then use the mSATA as the bootable OS drive, the 512GB m4 as the Data drive, and the older 256GB C300 as the Log drive.  I'm running the latest A09 firmware for the M6500 bios.

 

I received the drives on Monday afternoon, and here's what I've determined after many, many hours of fighting to get that setup operational:

 

- the mSATA SSD drive only works when SATA Operation is set to RAID in the BIOS.  When set to AHCI, the system will not post and always says "Minicard SSD Failure" whenever the m4 mSATA drive is installed.  BEWARE - while in AHCI mode, if you remove all the 2.5" SATA drives and leave only the mSATA, either physically or even just from the boot sequence in BIOS, you won't be able to get back into the BIOS without either pulling the CMOS battery or fitting the mSATA drive to an adapter so you can plug it into one of the 2.5" bays.

 

- with SATA Operation set to RAID, the system will not present the mSATA as a bootable drive when both 2.5" bays are occupied.  I verified that at least one other person has experienced this issue as well in ***Edit to remove Crucial competitor***

 

- with SATA Operation set to RAID, the system works AWESOME if you have only ONE 2.5" bay occupied.  I suspect it might also work if both bays were occupied and the SATA drives were configured as a single RAID 0/1 drive.  I didn't try this because it didn't align with my desired end state, and because I had existing data files on the 512GB 2.5" drive that I didn't want to lose.

 

So, the moral of the story is... for the M6500, don't expect to get 3 Crucial SSD drives up and running as separate, non-RAID drives.  If anyone has managed to get this working, PLEASE EMAIL ME ASAP.  If you'd like to get your OS running on the mSATA and use your existing SSD or spinning drive as a secondary hard drive, GO FOR IT.  That's the setup I'm using right now while I RMA the m4 mSATA back to Crucial and the only mSATA SSD that's I've found evidence will actually work in the M6500 in AHCI mode with both 2.5" bays occupied (see this link for details).

 

Now, on to lessons learned.  If you plan to clone your system drive, and/or switch your SATA Operation from RAID to AHCI or visa-versa, here are some links I think you'll find valuable:

 

- I wouldn't bother with any of the "top free drive imaging/cloning programs" like DriveImageXML, Clonezilla, Macrium, etc.  I attempted to use DriveImageXML to do a disk-to-disk clone of my running system drive, and it took over 2 hours and resulted in a CHKDSK of the new drive upon first boot and then a lot of file corruption in the OS.  Instead, follow the instructions here - How to Image and Replace a Hard Drive for a Server 2008 System - and use the GParted Live CD to copy and configure partitions.  GParted is my new best friend - It copied my ~100GB system partition to the new mSATA m4 drive in under 8 minutes.  It boots to LInux and gives you full access to do anything and everything you want to do with your drives and partitions.  Awesome.

 

- You'll see it in the post referenced above, but it's worth saying here too... Don't expect the new drive to just boot up after you've copied your image to it.  The new partition needs to have its boot flag set, and, at least in my case for my Server 2008 R2 system, you have to boot to the OS install CD and perform a repair on the partition in order to get the master boot record all sorted.  After that, make sure you remove your old system drive in case something goes wrong, and your new drive should boot up and work fine.

 

- If you find yourself needing to switch from AHCI to RAID, or visa versa, don't worry!  I've switched my system back and forth about 20 times since Monday with absolutely no ill effect on my drives or my data.  The key is to make sure you have the most recent Intel drivers installed for both RAID and AHCI, and then enable all the drivers needed for both modes in the registry.  Once that's done, you can switch back and forth to your heart's content without getting any BSOD errors.  Each time you switch, the OS will install the appropriate drivers, ask for a reboot, and that's that.  Reference this Microsoft KB - Changing SATA Operation - Don't Forget ATAPI - for the registry keys (Msahci, IastorV, and atapi) and this link to download and install the most recent Intel drivers - Intel Rapid Storage Technology (drivers only).

 

- Also, you'll find lots of posts about how AHCI is better and faster than RAID, and how TRIM only works in AHCI mode.  At least for the M6500, that's hogwash.  I ran CrystalDiskMark speed tests on both of my 2.5" drives in both modes and didn't see any noticeable difference in performance.  With respect to TRIM, it is enabled in both modes.  If anything, AHCI mode just reduces your options.  Also, since it's proprietary to the M6500's controller manufacturer, it evidently only supports a limited range of mSATA SSD drives, and the 256GB m4 mSATA doesn't appear to be one of them (hence the "Minicard SSD Failure" message on post whenever the drive is installed in AHCI mode).

 

Well, that's all I can think of.  Here's a shot of the underside of my M6500 with all three drives installed.  It's a shame I couldn't get it running this way.  Maybe Dell will come out with new BIOS firmware soon that either supports the m4 mSATA in AHCI mode or recognizes it in RAID with both 2.5" bays occupied.

 

 M6500 Crucialized.JPG

15 Replies
Kilobyte Kid

Re: 256GB m4 mSATA SSD Works in M6500 (... SORT OF)

Today I received my Crucial m4 128 GB SATA 6Gb/s mSATA SSD and tried to create the same configuration that you wanted without luck so far. Now I have 2 Hitachi 500GB HDDs as primary and secondairy drives. With the m4 I want the m4 as bootdrive and the other 2 HDDs as secondairy and third drives. The BIOS has recognised the m4 as a minicard SSD device, so thats good. However, in the list for selecting the device boot order there is no minicard drive available. Still searching for a solution. John
Kilobyte Kid

Re: 256GB m4 mSATA SSD Works in M6500 (... SORT OF)

Do you have BIOS set to AHCI or RAID? I couldn't get my M6500 to post to BIOS in AHCI mode. In RAID, the drive works great so long as only one of the 2.5" drives is installed. With both drives installed, I get the same behavior you're describing where it wouldn't let me boot to the mSATA drive and the drive disappeared from the boot sequence in BIOS.

Bummer!
Kilobyte Kid

Re: 256GB m4 mSATA SSD Works in M6500 (... SORT OF)

SATA is in RAID mode. I've got the same error like you when switching to AHCI. Error message is: "Minicard SSD failure. No boot device available - internal hard drive. No boot device available - second internal hard drive. No bootable devices.
I tested with BIOS A7 and A9.
And in RAID mode I cannot select the Minicard as a possible boot device. I'm not going to remove the second HDD. I need that 2x 500 GB....

John

Kilobyte Kid

Re: 256GB m4 mSATA SSD Works in M6500 (... SORT OF)

For the test I downgraded the BIOS from A09 back to A06, but the same issues remain. No possible selection of the Minicard as boot device. It's very strange how these guys made it happen: http://www.b2cit.com/faq_info.html?faqs_id=140 They have 2x HDD and an mSATA SSD and they can select the minicard as boot device !! Their BIOS version is A06, so that's what I tried to reproduce, but without luck. It seems unreproducable for now. John.
Kilobyte Kid

Re: 256GB m4 mSATA SSD Works in M6500 (... SORT OF)

Well, the guy in that post is using a different mSATA card.  The card he's using must work with the Intel controller in AHCI mode.  Unfortunately, that card doesn't have the performance of this m4 card, and it's even more expensive.  I'm looking into the 256GB drive from ***Edit to remove Crucial competitor*** at the moment.  I have a call into their tech line to find out if they know for sure if it will work with the M6500 in AHCI mode...

Crucial Employee

Re: 256GB m4 mSATA SSD Works in M6500 (... SORT OF)

Hi Joecole23,

 

I'm sorry to hear that you are having issues with your SSD drives.

 

I think the issue was created when enabling both RAID and AHCI drivers in the Registry.  Windows is possibly having issues when you connect a third drive due to this.  If you cloned the 2.5" to the mSATA SSD it's possible that the RAID set up is not seeing it as it's looking for 2.5" SATA ports.

 

This would explain why in AHCI it does not see the master boot record.

 

I would suggest you to install the C300 and M4 2.5” drives in AHCI mode and then remove the RAID capabilities from the Registry.  Then clone the desired boot drive to the mSATA and install and boot. At that point set up your secondary drives.

 

Another possible explanation is that his mSATA port is not enabled. I have seen this on other systems, where an mSATA port is available but not activated (usually it’s a second WIFI port), you would then have to activate it.

Crucial_Junket, Crucial Moderator, UK


________________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Re: 256GB m4 mSATA SSD Works in M6500 (... SORT OF)

Hey man,

 

Thanks for the suggestions.  Since I was in RAID before installing the mSATA drive, I never did try it without the RAID drivers enabled in the registry.  Unfortunately, switching the BIOS to AHCI and disabling RAID in the registry didn't get rid of the "Minicard SSD Failure" error.

 

The first thing I did was uninstall the Rapid Storage Technology software, which also uninstalled the Intel AHCI driver.  Then I went into the registry and set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStorV\Start to "3" (disabled).  Then, power down and using an mSATA to 2.5" adapter card, I installed the mSATA drive in the primary 2.5" bay and switched SATA Operation to AHCI in the BIOS.  With that setup (mSATA+adapter in the primary 2.5" bay, new m4 512GB in the secondary), the system boots to Windows and the default MS AHCI drivers are installed.  After a reboot (required by the driver activation), I powered down and moved the mSATA drive back to the FCM slot, booted it up, and got "Minicard SSD Failure".

 

Then, I moved the mSATA back to the 2.5" bay and installed the Intel AHCI driver.  After another reboot, I see the "Intel(R) 5 Series 6 Port SATA AHCI Controller" in Device Manager and everything looks good.  Power down, move the mSATA back to the FCM slot, boot up, and again, "Miincard SSD Failure".

 

So, with the iaStorV (RAID) driver disabled, I still get the "Minicard SSD Failure" error with both the MS and Intel AHCI driver installed.

 

Here's my question - do these drivers even matter if the error is happening before the system posts to BIOS?  When I get the error, if I press F2 to enter Setup, BIOS shows {none} for Minicard SSD.  However, in RAID mode, it sees the mSATA drive in the FCM slot without any problem (but won't boot to it if both 2.5" drives are installed).  This seems like a Dell BIOS firmware issue to me.  This would seem to be reinforced by the fact that the A02 firmware (now 4 versions old) says "Added support for Minicard SSD" under Fixes and Enhancements.  But I sure would like it if someone could answer that questions definitively!

 

With respect to my mSATA port not being enabled... I think it must be since the mSATA SSD works fine in the FCM slot with RAID enabled.

 

I'd really, really like to get this working.  Please let me know if you (or anyone else) has any ideas on how to address either the "Minicard SSD Failure" error in AHCI mode or that the system won't boot to the mSATA in RAID with both 2.5" bays occupied.

 

One last note - my mSATA has a perfectly valid MBR on it.  I used EasyBCD to copy the master boot record from the 100MB partition on my old C drive to the primary partition.  Then, I used GParted to clone that fully bootable primary partition to the mSATA drive.  I know it works because it boots to Windows just fine so long as I avoid the 2 configurations noted above.

 

Thanks for any help you can provide!

Bit Baby

Re: 256GB m4 mSATA SSD Works in M6500 (... SORT OF)

Hello everyone

 

I also would like to set up this same configuration: mSata + 2 HDD (and why not a 3rd HDD in optical bay)

I'm intereseted in bying this crucial m4 mSata 256GB but obviously I won't until I see a solution here

 

Hope you'll find out what's wrong Smiley Happy

Thanks!

Kilobyte Kid

Re: 256GB m4 mSATA SSD Works in M6500 (... SORT OF)

Unfortunately I stumbled upon this thread after I bought the m4 mSata 256GB Smiley Sad

 

m6500 BIOS is A09.

Running fine in AHCI with an m4 512GB 2,5" in slot 1 another HDD 500GB in slot 2 and an mSata 120GB of another company.

 

Putting the m4 mSata in my m6500 gives me the "Minicard SSD failure" at system start.

 

So I am pretty interested in a solution as well.