Crucial M500 SSD slowed down write speed on Macbook pro Yosemite

Kilobyte Kid

Crucial M500 SSD slowed down write speed on Macbook pro Yosemite

Hi,

 

One year ago I my SSD write speed was around 250Mb/s. 

Today, I'm testing it and it shows an speed of 250 only on its first and 2nd tests, then it goes down to less than 60Mb/s.

 

Why is this happening?

 

DiskSpeedTest.jpg

3 Replies
JEDEC Jedi

Re: Crucial M500 SSD slowed down write speed on Macbook pro Yosemite

You have no Trim on Yosemite.  The drives have Garbage Collection which will recover performance, but unlike trim, it takes time.  Under normal home user usage conditions (which is the market for Crucial drives - they're not enterprise class) this will happen naturally as you use the computer.

 

But If you use your drive to a write heavy environment that sees the drives getting no breaks in their work, such as say network monitoring (or, for some reason, consecutive benchmarking!! Smiley Wink ) you're going to need trim.

_______________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France |
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Highlighted
Dual Channel Surfer

Re: Crucial M500 SSD slowed down write speed on Macbook pro Yosemite

TRIM is useful as targetbsp mentions, but make sure that you are aware of the problems that you might encounter with TRIM and Yosemite. The following link explains:

 

http://www.cindori.org/trim-enabler-and-yosemite/

 

There are several other areas that can be a issue with the Macbook Pro.

 

Garbage Collection takes place during idle time, but this requires power to the SSD. Sometimes the SSD sleeps before garbage collection can be completed. In this case we need to prevent disks from sleeping and the simple way is to use system preferences.

 

System Preferences -> Energy Saver

Then take a look at the following option: Put hard disks to sleep when possible

 

This option should be unchecked.

 

Edit: also mentioned here:

http://forum.crucial.com/t5/Crucial-SSDs/My-SSD-used-to-be-so-much-faster-What-happened/ta-p/118310

 

===

 

That one change to disk sleeping alone might be enough, but if you are comfortable using the terminal, there are a number of settings that can be changed from within the terminal:

 

Disable hibernation:

sudo pmset -a hibernatemode 0
sudo rm /private/var/vm/sleepimage
sudo touch /private/var/vm/sleepimage
sudo chmod 600 /private/var/vm/sleepimage
sudo chflags uchg /private/var/vm/sleepimage

 

Most people do not sleep their Mac without main power for so long that the huge hibernation file is needed. This change is optional and the disk sleep changes should be enough.


===

Disable disk sleeping - disks will not get powered down.

This is pretty much a duplicate of disabling disk sleeping in Energy Saver Preferences mentioned above


sudo pmset -a disksleep 0


Disable Sudden Motion Sensor:

sudo pmset -a sms 0

 

The reasons for this one are explained here:
http://forums.macrumors.com/showthread.php?t=828861

 

===

 

In addition, sometimes the Macbook Pro will have a bad SATA cables and this will need to be replaced. This is not uncommon, although the slowing down after multiple tests would suggest a different problem in your case.

 

Bit Baby

Re: Crucial M500 SSD slowed down write speed on Macbook pro Yosemite

I had a very similar problem on my Mac mini with an M500 SSD, it lost a lot of speed after about 8 months. I fixed it by rebooting the Mac while holding down the alt key to bring up the boot menu and leaving it like that overnight.

 

This lets the garbage collection on the SSD do its thing and returned my drive to full speed.

 

Worth a try as it worked wonders for me.