EnhancedStorage / TCG Command error (Bitlocker, eDrive)

Kilobyte Kid

Re: EnhancedStorage / TCG Command error (Bitlocker, eDrive)

Right folks, no sign of progress from the official side (MS or Crucial) though at least Crucial have expressed an interest. I have some theories though, and I'm still working on it with determination. Don't lose heart yet, and do feed back as you conduct your own investigations/harrying of Crucial/MS. Stay tuned for updates from me.

Never give up, never surrender!
Kilobyte Kid

Re: EnhancedStorage / TCG Command error (Bitlocker, eDrive)

OK, so it is now gone midnight here and I still need to do some testing before I go fully public. I will tell you now though, my results are very good so far. I believe there is grounds for encouraging a little excitement.

I believe I have a good candidate for a solution to this problem. I intend to post my findings here tomorrow night. Hopefully including a solid solution. Fingers crossed... Smiley Happy~

Good night. I'm knackered.

Re: EnhancedStorage / TCG Command error (Bitlocker, eDrive)

I keep my fingers crossed! Smiley Happy


FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
How do I know what memory to buy?
Still need help? Contact Crucial Customer Service
Remember to regularly backup your important data!

Kilobyte Kid

Re: EnhancedStorage / TCG Command error (Bitlocker, eDrive)

Okay, so I've spent all night copying files which has taken more time than expected (they do build up). This is from my 3TB hardware encrypted hdd. I need to do a revert on that to test a non-crucial device. I'm away on business for a couple of days, so I'll fill you in at the weekend. Sorry to be a tease. Still, no lockups whilst running the system tonight, so looking good. I still see some errors in the event viewer, but W10 AU with bitlocker seems to be stable for now.

Details to come, but for those who want to experiment, try installing a pre-au build of W10 and getting bitlocker up and running after a diskpart clean or revert (I'm using revert for now) then engage bitlocker before updating to the au. You may want to clear your tpm in the firmware settings before you install Windows.

If you do get any black screens on a cold boot (I'm still not convinced this won't happen due to the triple errors in event viewer) try turning off fastboot for now. Warm boots I've tested a bit and that seems solid finally. As does general operation. Cold boots take a bit more testing. Watch out for hibernate as well, that also needs testing.

Time to really get things
Kilobyte Kid

Re: EnhancedStorage / TCG Command error (Bitlocker, eDrive)

Ooo, I got cut off! Time, I was saying, to get things fully discussed when I get back on Fri for the weekend.

Many Bothans died to bring us this information.
Kilobyte Kid

Re: EnhancedStorage / TCG Command error (Bitlocker, eDrive)

Further update: Unfortunately my method works, but not for long. The issue returns shortly after installing anything that encourages drive activity at boot time (such as large drivers like sound or vid card). The latest W10 update does supposedly address bit locker and TPM issues but not, it turns out, this one.

So, Crucial hardware encryption is no longer compatible with Windows 10. Not a great situation. Looking over the Interweb, I can't find the same being said of other Opal drives. Seems to be Crucial only.

The only work around is to clean install a pre-Anniversary Update version of Windows. And don't update it again. Since W10 forces updates, that means W8 or lower.

The only hope here is that Crucial are working on it, but there has been very little feedback since the team concerned was pointed on the direction of this thread.

So, firstly, if any Crucial folk could indicate this is being addressed that would be very helpful.

Secondly, can anyone recommend an SSD to replace the MX100 that is compatible with hardware bit locker on W10 post Anniversary Update going forward? The MX300 perhaps? Or, if Crucial no longer make a Windows 10 compatible hardware encrypted drive then another company's drive (if Crucial don't sell such anymore then you can mention other company's devices as they are no longer equiv. products competing against each other). Something that has been fully tested with hardware Opal bitlocker encryption on post AU W10, for sure. I can't hang about with my data all held as clear text with no indication that a solution is even being worked on, let alone nearing release. I can imagine trying to explain to my union members 'Sorry, your personal case data was all stolen whilst I hoped against all evidence that the encryption problem might have been looked at a bit... I'm sure it'll be fine...'. Scary.

Any input gratefully received.
Kilobyte Kid

Re: EnhancedStorage / TCG Command error (Bitlocker, eDrive)

Thank you for your investigation! Smiley Wink


To sum it up, it looks like there are two cases where it is broken now:


- Crucial SSD as primary OS drive: was working before, but doesn't work anymore since W10 anniversary update


- Crucial SSD as secondary (non-OS) data drive: didn't work reliably even before the W10 anniversary update



From my point of view, it has to be a problem within Crucials firmware. I have tried SSDs with hardware Bitlocker from another manufacturer and the ST3000DM002 in Bitlocker mode as primary and secondary drive, and in all cases they were running flawlessly.

Kilobyte Kid

Re: EnhancedStorage / TCG Command error (Bitlocker, eDrive)

Yes, I forgot to mention my ST3000DM002 works just fine, but I can't go back to an HDD boot drive of course.

I do like the Crucial quality hardware. It is a shame the encryption is so flaky on it. Even now I would consider an MX300 if I knew the encryption finally worked.

Of course, the MX100 et al ought to be fixable.

Crucial? What's your thinking? Anything doing?
Kilobyte Kid

Re: EnhancedStorage / TCG Command error (Bitlocker, eDrive)

So... it's been two years now since we discussed this problem here. Obviously there was no feedback anymore coming from Crucial.

Is there any information about the state of eDrive / hardware encryption in their newer drives? Is it still unusable?


If I google this problem I can find only complaints about MX100, MX200 and MX300, nothing about the newer MX500 drives. Problems like freezes, partitions becoming RAW after several reboots, all related to TCG Command errors.

In all cases, the proposed "solution" was to do stuff like installing Intel Rapid Storage drivers or setting registry keys that prevent Windows from switching the drives to OPAL mode, both things fixing the problem by removing the support for eDrive and hardware encryption (because even the latest Intel RST drivers are still blocking TCG commands, thus preventing Windows to enable eDrive). At the same time, Micron and Crucial are advertizing the benefits of eDrive and hardware encryption. Btw., I still haven't seen even one single report of a working setup of eDrive / Bitlocker hardware encryption on Crucial drives.


It's more like almost everyone who didn't install Intel RST drivers has these problems. I'm writing here again because I saw plenty of "funny" threads in the forum of my preferred (German) retailer where people got their (brandnew) Crucial drives exchanged 3 or 4 times because of freezing issues or wiped (RAW) partitions together with TCG command errors, and of course exchanging the drive didn't help at all because it's a firmware problem that hasn't been fixed for years. It's really strange that there seems to be no motivation at all for Crucial to just solve this problem.


Just my two cents...

Kilobyte Kid

Re: EnhancedStorage / TCG Command error (Bitlocker, eDrive)

Good news for anyone who is interested in Bitlocker hardware encryption!

I got my hands on a new MX500 and can confirm that eDrive is indeed working as expected and reliable without any issues. No TCG errors, no freezes, no sudden data partition wipe after each reboot.

Looks like the new controller they use in the MX500 is doing this job much much better...