M550 128MB (fw. MU01) - drive security locked

Kilobyte Kid

M550 128MB (fw. MU01) - drive security locked

Storage Executive ver 3.5 (installed in Windows 7 Pro 64bit) shows my M550drive is security locked.

It's connected as a second drive, Win7 disk management shows no partition on it, the drive is not behind RAID.

When I click PSID revert tab in Storage Executive it says no drives found supporting PSID revert operation.

How can I access this drive?

2 Replies
Community Manager

Re: M550 128MB (fw. MU01) - drive security locked

Hello sla_fed,

Thank your message. Sorry to hear you are having problems with your SSD.

So I can correctly diagnose the problem, I would like to know more about your SSD and how it has been used. In some cases it is possible to restore an SSD to full functionality simply by reconfiguring it.

Could you please confirm as much of the information below as possible:

- What is the SSD part number printed on the sticker (starting CT):

- Have you upgraded the firmware to the latest version MU02?

- Serial number/date code from the sticker on the drive:

- What were you wanting to do with the drive when you discovered it was security locked?

- Tell us of any troubleshooting steps you have attempted prior to contacting us:

- When did the problems first occur?

- The exact system or motherboard model the SSD is used in:

- Have you tried it in another system?

- Have you tried different SATA cables and ports on the motherboard (desktop users only), or connected it externally via USB?

- What BIOS SATA mode are you using (IDE/ AHCI/ RAID)?

If I can be of further assistance or you have any other questions, then please do not hesitate to contact me.

Kind regards,

Crucial_NG, Crucial Moderator, UK

How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Re: M550 128MB (fw. MU01) - drive security locked


- firmware is MU01 and I can't upgrade it to the latest version MU02 when the drive is in security locked mode

- the SSD part number: CT128M550SSD1

- serial number: 14020C041713

- I am not the first owner of the drive so I don't know what happened to the drive in the past

- curently I'm using Intel DH67BL motherboard

- I tried the drive on different motherboard, different cable and different ports

- BIOS SATA mode I'm using is AHCI

- I tried it in Windows 7 Pro 64bit, Windows 10 Pro 64bit and Ubuntu linux.