M550 broken after f/w update

Kilobyte Kid

M550 broken after f/w update

I made upgrade f/w my M550 (MU01 to MU02) via botable usb memory.
Unfortunately, I forgot that I have a uefi bios (!!!)
The M550 was a system disk.
During the upgrade there was a message about the number of sectors (with error) but then the update was successful.
Now Win 8.1 does not boot, the boot repair from dvd does not work because it does not find the disk. Command Prompt: Bootrec / fixmbr i / fixboot generates device error in / out
Uefi shows the connected drive, the name is correct. But Windows installer hangs on AHCI mode, only in IDE mode works. (but he can not see the disk for repair/install)
Under Ubuntu, I see 4 partitions on the disk (Windows recovery, Efi system, MS reserved, Data), the files are probably intact, but when copying the transfer is low, it decreases and hangs. Gparted sees the disk but reports error: Error fsyncing/closing /dev/sdb1: input/output error - and the same for sdb2, sdb3, sdb4
It looks like ssd is corrupted by the software.
Does anyone have an idea how to restore it to action, restore the partition operation or the full format for a new system?



5 Replies

Re: M550 broken after f/w update

I would suggest running "smartctl" from Linux to check on the firmware level of the SSD and also the SMART Attributes.  Feel free to post this if you need help to understand the information (blank out the SSD serial# first).


If you need to get your data off the drive I would use Linux to clone the SSD to an image file using GNU ddrescue  in Linux (available from Ubuntu repository).    Make sure to unmount all of the SSD's volumes first.  Once the image is made, then you can mount the image file and copy the files from it.    You can also clone the whole SSD to another drive as well if you want, as it is a bit easier for some people.  Make sure to use a logfile so you can resume the clone if you stop it or are interrupted.  (Also use the following flags "-dv --ask".)   I recommend cloning to an image file because it leaves you with options.   If the filesystem needs repaired you can make another copy of the image file to work on or the image file can be restored to another drive to attempt repairs.


If this doesn't work, then a professional data recovery service such as Drive Savers is your best option if you need the data recovered.  Drive Savers will provide a free estimate and I believe you only pay if they recover data (but SSDs may be different).   If the cloning process seems slow, I would stop it and check the SMART Attributes against the original values.   If the values are getting worse you will need to decide whether to continue and risk making things worse & losing data.


I've never had to recover data from a failing or defective SSD so I'm not sure exactly what to expect.   When an SSD is malfunctioning I have seen the SMART Attributes get worse even when the SSD is just sitting unmounted.  This might get fixed after a firmware update and Secure Erase, but until then your data could be at risk.   If you have data you must retrieve because it is not backed up, then you may want to consider using a professional data recovery service instead of attempting recovery yourself because if you fail it might make the data harder or even impossible to retrieve.


If the firmware did not update, then I would burn the firmware updater to a USB drive and try upgrading it again, but only after you have retrieved your data.   You can use Linux to make the bootable USB updater by running "isohybrid" on the .ISO file before "dd"ing the image to a USB drive.  Make sure the SSD is connected to an internal controller in AHCI mode.


Finally I would perform an ATA Secure Erase before trying to reinstall Windows as this erases & resets the SSD and it may correct any outstanding issues.   This can be done from Linux or by using Parted Magic.


If you need more specific instructions let me know.

Kilobyte Kid

Re: M550 broken after f/w update

Thank you for the hints.
I made a bacup of important files under Ubuntu. Difficult but managed (transfer has been suspended many times)
I tried to re-load the MU02 firmware via bootable pendrives, but there is a message that ssd does not require it.
I connected sdd to another computer as an additional disk. First, it blocked the system start-up, I had to plug in the power plug only after windows started to run. The Crucial Storage Executive does not always recognize it, and if so it gives f/w MU02 and there is no update. Also gives 100% full (should be about 15% of free space) and sdd 128 C temperature!
I launched Parted Magic but this one claims that the drive does not support Secure erase, and should it? I run the usual Wiping data and the first 4GB went immediately and the speed went down to 100-200kB / s and after 30min I have made 1% and 37 hours to the end.
It should not be so, the drive has a significant slowdown through badly uploaded firmware. Is there any software to upload the firmware unconditionally in the ssd controller, as it is done during the production process?
Or maybe there is a Crucial service point to send the disk for repair?


Re: M550 broken after f/w update

In order to Secure Erase the SSD it needs to be connected to an internal SATA controller in AHCI mode (I've been successful using an eSATA add-in card too.  I never had any luck hot-plugging a drive on an internal SATA controller).  If Parted Magic isn't able to do this, you could try the same thing from the Linux command line.


I saw a forum post on another site which wondered if the firmware could be pushed to the SSD using "hdparm" or "flashrom", but I don't think anyone ever risked their SSD.


If you are unable to update the firmware again or Secure Erase it, then the drive is probably dead.  I would contact Crucial Support directly to see if there is any way to get the drive working again.


It might be useful to see what errors are produced when the M550 is connected to the system.  This is easiest to do by booting to Linux and then connecting the drive by USB (or eSATA) so the errors are at the end of the log and easily captured.  It is hard to say whether Crucial would be interested in reviewing the errors in order to assist you in resurrecting your M550.


It is easiest to open two terminal windows so you can capture & view the errors, while issuing commands in the other window.


Before connecting the M550, start capturing the log with the following command (to end the capture press Ctrl + C).  The command will display kernel messages in the terminal and also record it to the "SSD-Kernel-log.txt" file in the home folder.   


sudo    tail  -f   /var/log/kernel.log   |   tee   -a  ~/SSD-Kernel-log.txt

Then connect the M550 and watch for kernel messages about the M550.  You should see the SSD's drive designation in the log in the form of "sdb", or "sdc", etc.  Wait several minutes to see if any additional messages are recorded before running any commands.  Some Linux systems automatically mount connected drives too.   


Open another Terminal window and attempt to retrieve the drive's SMART information: 

sudo    smartctl  -a  /dev/sdX   |   tee  -a   ~/SSD-Smart-log.txt

Replace the "X" in "/dev/sdX" with your SSD's identfier seen from the kernel log.   You can confirm the M550's designation from those SMART Attributes and by the following command which will list all connected drives along with thier labels and filesystems:

sudo   lsblk   -f   

If the M550 is connected to SATA or eSATA, then you can attempt an ATA Secure Erase and  see if any messages appear in the logs during the attempt.  First see if the ATA Security is still enabled after using Parted Magic and see if the drive is frozen.


sudo    hdparm   -I   /dev/sdX

Again, replace the "X" in "/dev/sdX" with the M550's designation.  If the Security state shows "enabled" then you need to disable it using the password Parted Magic used (may have to search online for it).

sudo    hdparm   --user-master  u   --security-disable    parted-magic-password    /dev/sdX

If the M550's state shows "frozen" then you need to put the system to sleep for a moment and wake it up.  Run the command again to make sure it shows "not  frozen".   Then issue the following three commands again replacing the "X" with the M550 designation.  The first command will unmount the first nine mounted volumes on the M550, the second command sets the security on the M550, and the third command actually performs the Secure Erase.

sudo   umount  /dev/sdX{1..9}

sudo hdparm --user-master u --security-set-pass Eins /dev/sdX sudo hdparm --user-master u --security-erase Eins /dev/sdX

The third command usually takes only a minute to finish on a working SSD.  In your case be patient and see if it will ever finish.


You can also try connecting the MX550 to power only (no data connection) and see if perhaps it can heal itself (let it go a day or more).   Or leave it disconnected and try again much later after some of the components have been discharged.   At this point you are just grasping at straws.

Kilobyte Kid

Re: M550 broken after f/w update

Unfortunately, I am not advanced in the Linux system and I was unable to save the log's to the file. I am using Ubuntu Live and maybe there is something missing in my system.
Then I tried with hdparm:

ubuntu@ubuntu:~$ sudo hdparm -I /dev/sda


ATA device, with non-removable media
Model Number: Crucial_CT256M550SSD1
*removed personal information*
Firmware Revision: MU02
Transport: Serial, ATA8-AST, SATA 1.0a, SATA II Extensions, SATA Rev 2.5, SATA Rev 2.6, SATA Rev 3.0
Used: unknown (minor revision code 0x0028)
Supported: 9 8 7 6 5
Likely used: 9
Logical max current
cylinders 16383 16383
heads 16 16
sectors/track 63 63
CHS current addressable sectors: 16514064
LBA user addressable sectors: 268435455
LBA48 user addressable sectors: 500118192
Logical Sector size: 512 bytes
Physical Sector size: 4096 bytes
Logical Sector-0 offset: 0 bytes
device size with M = 1024*1024: 244198 MBytes
device size with M = 1000*1000: 256060 MBytes (256 GB)
cache/buffer size = unknown
Form Factor: 2.5 inch
Nominal Media Rotation Rate: Solid State Device
LBA, IORDY(can be disabled)
Queue depth: 32
Standby timer values: spec'd by Standard, with device specific minimum
R/W multiple sector transfer: Max = 16 Current = 16
Advanced power management level: 254
DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 *udma5 udma6
Cycle time: min=120ns recommended=120ns
PIO: pio0 pio1 pio2 pio3 pio4
Cycle time: no flow control=120ns IORDY flow control=120ns
Enabled Supported:
* SMART feature set
* Power Management feature set
* Write cache
* Look-ahead
* Host Protected Area feature set
* WRITE_BUFFER command
* READ_BUFFER command
* NOP cmd
* Advanced Power Management feature set
SET_MAX security extension
* 48-bit Address feature set
* Device Configuration Overlay feature set
* Mandatory FLUSH_CACHE
* SMART error logging
* SMART self-test
* General Purpose Logging feature set
* 64-bit World wide name
Write-Read-Verify feature set
* Gen1 signaling speed (1.5Gb/s)
* Gen2 signaling speed (3.0Gb/s)
* Gen3 signaling speed (6.0Gb/s)
* Native Command Queueing (NCQ)
* Phy event counters
* NCQ priority information
* DMA Setup Auto-Activate optimization
Device-initiated interface power management
Asynchronous notification (eg. media change)
* Software settings preservation
Device Sleep (DEVSLP)
* SMART Command Transport (SCT) feature set
* SCT Write Same (AC2)
* SCT Features Control (AC4)
* SCT Data Tables (AC5)
* reserved 69[4]
* reserved 69[7]
* Data Set Management TRIM supported (limit 8 blocks)
* Deterministic read ZEROs after TRIM
Logical Unit WWN Device Identifier: 500a07510c086b31
NAA : 5
IEEE OUI : 00a075
Unique ID : 10c086b31
Device Sleep:
DEVSLP Exit Timeout (DETO): 50 ms (drive)
Minimum DEVSLP Assertion Time (MDAT): 10 ms (drive)
Checksum: correct


I do not see any Security option. I tried it just in case:


ubuntu@ubuntu:~$ sudo hdparm --user-master u --security-disable parted-magic-password /dev/sda
security_password: "parted-magic-password"

Issuing SECURITY_DISABLE command, password="parted-magic-password", user=user
SG_IO: bad/missing sense data, sb[]: 70 00 05 00 00 00 00 0a 04 51 60 00 21 04 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
SG_IO: bad/missing sense data, sb[]: 70 00 05 00 00 00 00 0a 04 51 60 00 21 04 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00


I guess it does not look good.

After unmounting all partitions:

ubuntu@ubuntu:~$ sudo unmount /dev/sda1
sudo: unmount: command not found
ubuntu@ubuntu:~$ sudo umount /dev/sda1
umount: /dev/sda1: not mounted
ubuntu@ubuntu:~$ sudo umount /dev/sda2
umount: /dev/sda2: not mounted
ubuntu@ubuntu:~$ sudo umount /dev/sda3
umount: /dev/sda3: not mounted
ubuntu@ubuntu:~$ sudo umount /dev/sda4
ubuntu@ubuntu:~$ sudo umount /dev/sda4
umount: /dev/sda4: not mounted
ubuntu@ubuntu:~$ sudo hdparm --user-master u --security-set-pass Eins /dev/sda
security_password: "Eins"

Issuing SECURITY_SET_PASS command, password="Eins", user=user, mode=high
SG_IO: bad/missing sense data, sb[]: 70 00 05 00 00 00 00 0a 04 51 60 00 21 04 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00


It looks like ssd generates errors in / out that previously confirmed gparted, do I understand this well?

Now I leave it turned on for 24 hours maybe longer and see if something will improve, although honestly doubts. I spoiled everything by updating it in the wrong way, it's a pity that Crucial did not protect it, or that I did not think about it three times before ...

Thank you for your time and commitment. I think it's just fixing the Crucial service, if there is a possibility and they wants to fix it and how expensive it is.




Re: M550 broken after f/w update

The output from "hdparm" doesn't seem to show the Security section.   The security section is usually displayed in the last dozen or so lines.   It should also list "Security Mode Feature Set" on the second line in the "Command/features" section right after "SMART Feature Set".


Unless it can fix itself by being disconnected from power for a while or by self healing with it connected only to the power (no data cable), it looks like it is dead.   It wouldn't hurt contacting Crucial Support directly to see what it might cost to have it repaired if that is even an option.


From your original post it would appear the firmware was updated successfully and it does show the MU02 revision in your last post.   I'm wondering if maybe the M550 was already having issues and the firmware update put it over the edge.   If only the firmware could be reapplied.   Very unfortunate circumstances.


BTW, If my commands were used when booted from a Knoppix Live USB drive it will allow you to save the files locally on a Data partition on the USB drive.   Then you can move those log files to another drive.  Otherwise an Ubuntu Live system should still temporarily save those log files in memory so you could transfer them to another drive or you could modify the path in my commands to save them to another mounted drive or USB stick.


FYI, sorry for not being clear, but for the command where I mentioned "parted-magic-password" you would need to substitute that phrase with the actual password Parted Magic would have used.   I'm not sure if they mention it anywhere in their documentation.   I just wanted to clarify for anyone else making the attempt.

If the Security state shows "enabled" then you need to disable it using the password Parted Magic used (may have to search online for it).

sudo    hdparm   --user-master  u   --security-disable    parted-magic-password    /dev/sdX

FYI, if you do post anything else from your SSD, make sure to edit the file to remove the SSD's serial number.


If you do resolve this issue, please update this post to let us know.