MX100 MU02 Firmware

Kilobyte Kid

MX100 MU02 Firmware

Hi,

 

just upgraded my MX100 128GB to MU02 FW trough Storage Executive. Why does FW download page says "No firmware updates" if it has one? 

Capture.PNGCapture2.PNG

17 Replies
JEDEC Jedi

Re: MX100 MU02 Firmware

Read message 96 onwards on page 10 of this thread: http://forum.crucial.com/t5/Crucial-SSDs/Feedback-Thread-Firmware-MU02-for-M550/td-p/163398/highligh...

 

In short, we don't really know on here what's going on with regards to that!

_______________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France |
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Highlighted
Dual Channel Surfer

Re: MX100 MU02 Firmware

It seems strange to me and as pointed out by targetbsp, this is the second report of this problem.

In both cases it was a MX100 128GB drive.

 

Two theories so far...

 

1. There was a beta release of new MX100 firmware that should not have been released to the public and a few people received it when they shouldn't have.

2. The Storage Executive software sometimes incorrectly identifies the MX100 and M550 drives, which both use the same Marvell 88SS9189 controller. Perhaps the firmware for the M550 can be installed and run on the MX100 controller, and this is what happens, but perhaps not optimized.

 

I guess we have to wait and see what Crucial come back with when they investigate this.

bgt
Kilobyte Kid

Re: MX100 MU02 Firmware

My MX100 128Gb updated to MU02 also trough Storage Executive. But now it does not see the 2 crucial drives in Storeage Executive anymore.  The other one is a M500 960Gb.

Strange eh. PC runs normal BTW.

How to find the MU01 FW? Is it possible to go back in FW version?

Asrock Z87M-Extreme4(C2)/i7-4770K/8Gb1600/SSD(128GbMX100+ 960GbM500)/IGP/
OS=Win8.1 X64 PRO(UEFI mode)
JEDEC Jedi

Re: MX100 MU02 Firmware


@bgt wrote:

 

How to find the MU01 FW? Is it possible to go back in FW version?


Nope.  No-one ever needs to upgrade to the first firmware of anything.  So it never exists in a user flashable version.  It's only ever installed from the factory.

 

In any case, you shouldn't flash backwards a firmware version in some cases.

 

 

You're far better off waiting for the official word back on this than messing around with it and potentially making it worse. Smiley Happy

_______________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France |
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Dual Channel Surfer

Re: MX100 MU02 Firmware


@bgt wrote:

How to find the MU01 FW? Is it possible to go back in FW version?


These are some options in the msd-config.sh script inside the M550 FW02 update tool (the one supplied in ISO file) that would appear to allow the user to specify the rssd-downgrade-version.

 

We can't use the downgrade if we don't have the MU01 FW and i don't think Crucial would support this for end users. But it appears that Crucial/Micron would be able to revert the drive FW if it was returned under warrenty. In the meanwhile if the drive is working, let's wait and see what they come back with.

 

bgt
Kilobyte Kid

Re: MX100 MU02 Firmware

Thanx, I'll just wait for a FW update. Everything works OK.

Asrock Z87M-Extreme4(C2)/i7-4770K/8Gb1600/SSD(128GbMX100+ 960GbM500)/IGP/
OS=Win8.1 X64 PRO(UEFI mode)
Kilobyte Kid

Re: MX100 MU02 Firmware

grabavozas, bgt,

Were either of you experiencing disappearing drives, or BSODs in Windows, under MU01?

If so, has MU02 (be it beta or whatever) fixed the problem for you?

A lot of people are having their MX100 disappear from their systems only to come back after a power off.

Really hoping MU02 fixes this and I'm curious if the version you installed has.

Thanks.

Kilobyte Kid

Re: MX100 MU02 Firmware

Looks like the MU02 firmware for the MX100 is available.  I'm going to try to install it tonight - hopefully it resolves some of the issues I've been having.

Kilobyte Kid

Re: MX100 MU02 Firmware

Unfortunatly the new firmware isn't available in Storage Executive and the Bootable CD on the Crucial website doesn't detect my drive under ATA, AHCI or RAID modes.
Really fed up with Crucial right now. Their support is a joke.