Problem with new Crucial M4 SSD 128 GB

Bit Baby

Problem with new Crucial M4 SSD 128 GB

Hi all! Yesterday I received the SSD. I was very happy and I started to install Windows 8. When it finished installing, the SSD didn't boot the operating system, so I decided to reinstall Windows. This time it booted good, I configured all, I started installing things but suddenly, Windows get stuck. I can't do nothing because I have to press the reset button.


Today I've tried one more time to install windows, but now my ssd seems to have 0MB.

What can I do? I'm going to install the latest firmware but I think that will not solve anything.


Thanks in advance!


Sorry for my english.

2 Replies
Kilobyte Kid

Re: Problem with new Crucial M4 SSD 128 GB

Worst case scenario, return the M4 to the retailer and try your luck with another SSD manufacturer.  I wish I had that option, but my M4 started to fail after the refund time expired.  In the meantime lets get some more info and try to diagnose the problem you are having...


What version firmware did the M4 come with?

What controller is the SSD attached to?

Are you using MSAHCI SATA driver or another one?

Is the M4 in a laptop/desktop?

What is the MB/Chipset?

Crucial Employee

Re: Problem with new Crucial M4 SSD 128 GB

Hi jmascarell,


I'm sorry to hear you are having problems with your SSD.  To help us establish the cause of the issue, could you please confirm as much of the information below as possible:

- What exact issues are you having?

- How long has the drive been in use?

- When did the problems first occur?

- What is the SSD being used for? (O/S, Storage, Page File, etc.)

- What is the SSD part number printed on the sticker (starting CT):

- Your exact system or motherboard model:

- Have you tried it in another system?

- Your current BIOS revision:

- Do you know your SATA speed (SATA-I 1.5Gb/s, SATA-II 3.0Gb/s, SATA-III 6Gb/s)?

- Operating system:

- What color or number is the SATA port the drive cable is connected to (Desktop users only)?

- Have you tried different SATA cables (Desktop users only)?

- Have you tried different SATA ports (Desktop users only)?

- Do you have more than one bay for hard drives/SSDs and have you tried the different bays (Laptop users only)?

- What Firmware version is printed on the sticker on the drive?

- Have you upgraded this and if so, what is the current version?

- What BIOS SATA mode are you using (IDE/ AHCI/ RAID)?

- Do you have screen shots available (if relevant)?

Once we have the above information we would be more than happy to look in to this further for you.

Crucial_Junket, Crucial Moderator, UK

How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?