Solved M4 not seen by laptop BIOS SSD not removed (I hope)

Kilobyte Kid

Solved M4 not seen by laptop BIOS SSD not removed (I hope)

I have a solution to my Crucial M4 512Mb 2.5" which is a week old occasionally not being recognised on startup by bios of my laptop without removing the SSD.
The laptop is Samsung Q210 Part No NP-Q210H. It has a Phoenix BIOS. M4 firmware update from crucial-M4.010G.01.00.iso booting laptop from a USB emulating the CD.

On 3 occasions the Crucial M4 was not recognised in this or another computer. It was recognised by the Curical firmware update software which detected the firmware above and would not allow it to be re-installed. Here is how I sorted the problem 3 times without removing the SSD.

 

NOTE 6 Dec 2012- I now boot into a recent version of Perted Magic on a USB drive . It appears to reset the locked drive when it starts. You see this happening during the message like "Detecting system devices" which takes a couple of minutes and then the startup continues. However, the M4 SSD  will not appear in GParted or elsewhere until you reboot the computer again. Also note that old versions of Parted Magic (like 4.8) do not work, I used version 2012_10_10 from here

1. When the M4 is not recognised by the BIOS and there is no other device (CD, USB, eSATA disk) it will hang for a few minutes and eventually show the Main screen with no boot device present. 

2. At that point I got to Exit. I will be asked if I wish to save the settings Y/N. I do nothing and leave the laptop in this state for a few minutes. I think that it has been for less than 10 minutes but more tha 5 minutes.

3. Then I hold down the power button to switch the laptop off. When I reboot after doing this the SSD is recognised normally and no data has been lost. (I think that I may have had to do this twice on one occasion.) I suggest that if it is not recognised you wait 5 more minutes and try again.

This has worked 3 times so far. I do not know what had caused the problem but I think it might be connected with the power being turned off on the laptop power supply. I might be due to a previous boot with a USB pendrive previously

The M4 will boot with it in SATA Port 1, set up with ACHI either Enabled or Auto. (Auto detects if WinXP does not have a SATA/ACHI driver and disables ACHI).

I have also tried the Power Cycling suggested by Crucial by removing the SSD and used the power cable only to perform a 3 20 minute power cycle. This does not seem to be needed.

I hope this keeps working and will be of use to other latop users, so that they do not have to remove the SSD. It seems to me that if the M4 is left with power on for some minutes that it resets itself, but I know little about these devices. I am pleased that I have not lost any data.

 

I run Linux Mint 13  LTS (Long Term Support) http://linuxmint.com/ with Xfce 4.10. The SSD is so fast that I am wondering about returning to KDE Desktop which tends to be slow on a HD. I installed the SSD so that I could use the laptop while travelling on coach journeys and I was concerned that the bumping would afftect the HD. Added benefits are the speed and the near doubling of battery life to 4 hours.

5 Replies
Kilobyte Kid

Re: Solved M4 not seen by laptop BIOS SSD not removed (I hope)

Same problem recurred again and the solution I gave solved it without removing SSD from laptop.

 

I think I know what caused the SSD not to be detected. I have rebooted the laptop containing the M4 SSD with many differnent USB drives with different Linux systems on them, perhaps 30 times, with no problems. However, as soon as I accidentally booted from a USB setup with crucial-M4.010G.01.00.iso the SSD was seen by Crucial software and not updated because it contained the latest update. Immediately after that on the next boot the M4 SSD was not detected.

Highlighted
Kilobyte Kid

Re: Solved M4 not seen by laptop BIOS SSD not removed (I hope)

When the M4 isn't recognized in your laptop you do the following:

 

Go into BIOS and then Exit the BIOS. When it asks to save the changes/settings Y/N, you do nothing and let it sit at the Y/N screen for about 5-10 minutes.  Then you press the Power button to shutdown and press it again to Boot.

 

Is this correct hamamelis?  Thanks.

Bit Baby

Re: Solved M4 not seen by laptop BIOS SSD not removed (I hope)

This issue also happened to me earlier this evening. Works like a charm, thanks for the tip!
Crucial Employee

Re: Solved M4 not seen by laptop BIOS SSD not removed (I hope)

Hi hamamelis,

 

Thanks for posting your findings.

 

This could be of great use to future customers with the same problems.  If you need anything else at all in the future please don't hesitate to contact us and we would be more than happy to help.

Crucial_Junket, Crucial Moderator, UK


________________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France | Global
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
We want your feedback! Post in the Suggestion Box
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Re: Solved M4 not seen by laptop BIOS SSD not removed (I hope)

Any idea how to do this on a MacBook Pro?