[Solved] Storage Executive Tool doesn't recognize SSD although it works

Kilobyte Kid

[Solved] Storage Executive Tool doesn't recognize SSD although it works

Hi,

 

I've installed a Crucial M550 mSATA SSD. I installed windows 7 (32bit) on it, includig all necessary drivers and updates, and all seems to work fine, except your Storage Executive Tool which says "no supported drives found in the system". (Only the System Information page works.)

 

AHCI is supported and activated; Windows is starting properly in AHCI mode (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci\Start=0).

 

The dealer which sold the SSD (www.snogard.de) asserted that Intel Rapid Storage Driver must be installed. Is that true? I can't believe it, as this is afaik a proprietary and chipset-dependent technology and not a generic standard. My system doesn't support it, so I can't install such drivers.

 

Any hints how to get the executive tool work? What can be the reason of the failing SSD detection? Could it be an indication that the SSD is a fake which ist not originally from Crucial? (Although labels are suggesting an original product.)

 

Thanks in advcance!

 

Edit: marked as solved.

12 Replies
JEDEC Jedi

Re: Storage Executive Tool doesn't recognize SSD although it works


@mawl wrote:

 Could it be an indication that the SSD is a fake which ist not originally from Crucial? (Although labels are suggesting an original product.)

 

 


No, it's not indicative of that if that is your main concern.  Crucial have never been that great at detecting their own drives in a Windows environment.  "Try the manual boot disc version" (which uses freedos/linux) is a frequent response on here to the question "why can't the windows firmware update see my drive?"

 

_______________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France |
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Re: Storage Executive Tool doesn't recognize SSD although it works

Thanks for your fast answer!


"Try the manual boot disc version"

That seems to be firmware-related only, but is there also a self booting standalone tool available with the same full functionality as Storage Executive Tool? If yes, where? I searched a lot on crucial and micron webpages, but I couldn't find one.

 

If not, is there a trick or workaround which can enable the Storage Executive Tool to detect my SSD anyway and to do what it is made for?

 

Regards,

Community Manager

Re: Storage Executive Tool doesn't recognize SSD although it works

Hi Mawl,

 

I am sorry for the issues that you are experiencing. What is the make and model of the system that you have the SSD installed in?





YogiH, Crucial Moderator, US


________________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France |
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Re: Storage Executive Tool doesn't recognize SSD although it works

 

Don't laugh, it's my attempt to bring new life and speed into my good old ASUS EeePC 901 - with 2 GB RAM and a special adapter to compensate for the pinout differences between Asus' FLASH_CON connector and standard mSATA. (The original Asus BIOS doesn't even support AHCI, but a patched version does.)

 

All works perfect so far, it couldn't be better, except the said problem.

 

But in the meantime, I'm a small step further. Inspired by targetbsp, I booted a Linux live system from external DVD drive (without installing it), and tried to run the Linux version of the Storage Executive Tool. Instant success! Unlike it's windows counterpart, it had no problems to recognize the SSD and handle it. I was able to view the SMART data, for example, and performed the suggested firmware update with success. So targetbsp was right in suspecting that the problem is specific to the Windows platform - hardly to understand and somewhat awkward, as this is probably the most common application scenario.

 

Maybe this information is helpful. Obviously, I would still prefer to use the windows version on a windows system. ;-)

 

Thanks in advance,

JEDEC Jedi

Re: Storage Executive Tool doesn't recognize SSD although it works

I would try to install 11.2.0.1006 version of Intel RST driver (it's under A. "Classical" Intel RST Drivers and their RST Software" section) however I wouldnt't suggest that to you in case all works perfect for you.

 

As for the Linux version of the Storage Executive Tool - have you used the one that is available on micron site? What is the drive ID you can see in device manager (starting with CT...)?

______________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France |
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Re: Storage Executive Tool doesn't recognize SSD although it works


@bogdan wrote:

I would try to install 11.2.0.1006 version of Intel RST driver (it's under A. "Classical" Intel RST Drivers and their RST Software" section) however I wouldnt't suggest that to you in case all works perfect for you.


Heureka! This (unofficial?) version of Intel RST driver has been accepted even on my old system, I can't believe it! And with it, the Storage Executive Tool is working properly! Thanky you very very much! I would have never found it alone!

 

And also thanks to all other guys in this thread! Good synergy. Every single post was a step in the right direction and has brought me further!

 

Conclusion: Problem solved. 

JEDEC Jedi

Re: Storage Executive Tool doesn't recognize SSD although it works

Nah it's not unofficial, it's just old.  It's also a pretty great version.  I swore by it on my previous PC. Smiley Very Happy

_______________________________________
How do I know what memory to buy?
Shop for your region: US | UK | EU | France |
I think my memory is bad. What do I do now?
FAQs and Top Forum Solutions
Did a user help you? Say thanks by giving Kudos!
Still need help? Contact Customer Service
Want to be a Super User?
Kilobyte Kid

Re: Storage Executive Tool doesn't recognize SSD although it works

Welp, sory to necro this post, but I'm running into a similar issue.  The motherboard is a GIGABYTE GA-990FXA-UD3, which I confirmed as being compatible with the Crucial MX100 512GB drive I'm using.  For whatever reason, the Executive tool does not recognize the drive, although it works fine.  I ended up having to make a bootable disk for the firmware upgrade, but even then I still cannot detect the drive with Crucials tool.  Anyone able to help?

Highlighted
Kilobyte Kid

Re: Storage Executive Tool doesn't recognize SSD although it works

Necroing this for info posting reasons.

 

The storage executive simply cannot see drives that are picked up as SCSI\Disk, this is a significant limitation of the crucial software on windows as most of the third party controller drivers and IRST/IRSTe drivers > 11.5 report them as SCSI\Disk instead of IDE\Disk which is what MSAHCI and RST 11.2 and older use.